software/hoardy-web/./extension/default.nix

Passively capture, archive, and hoard your web browsing history, including the contents of the pages you visit, for later offline viewing, mirroring, and/or indexing. Your own personal private Wayback Machine that can also archive HTTP POST requests and responses, as well as most other HTTP-level data.

Files

Raw Source

Contents

{ pkgs ? import <nixpkgs> {}
, lib ? pkgs.lib
, source ? import ../source.nix { inherit pkgs; }
}:

with pkgs;

stdenv.mkDerivation rec {
  pname = "hoardy-web-extension";
  version = "1.16.0";

  inherit (source) src unpackPhase;
  sourceRoot = "${src.name}/extension";

  nativeBuildInputs = [ git jq pandoc zip imagemagick vim.xxd ];

  buildPhase = ''
    ./build.sh clean firefox chromium-mv2
  '';

  installPhase = ''
    mkdir -p $out
    git archive --format tar.gz -o $out/Hoardy-Web-source-v${version}.tar.gz extension-v${version}
    cd dist
    cp -at $out *.xpi *.zip *.crx
  '';
}