Passively capture, archive, and hoard your web browsing history, including the contents of the pages you visit, for later offline viewing, mirroring, and/or indexing. Your own personal private Wayback Machine that can also archive HTTP POST
requests and responses, as well as most other HTTP
-level data.
{ pkgs ? import <nixpkgs> {}
, lib ? pkgs.lib
, source ? import ../source.nix { inherit pkgs; }
}:
with pkgs;
python3Packages.buildPythonApplication rec {
pname = "hoardy-web-sas";
version = "1.7.0";
format = "pyproject";
inherit (source) src unpackPhase;
sourceRoot = "${src.name}/simple_server";
propagatedBuildInputs = with python3Packages; [
setuptools
cbor2
];
}