software/hoardy-web/./simple_server/default.nix

Passively capture, archive, and hoard your web browsing history, including the contents of the pages you visit, for later offline viewing, mirroring, and/or indexing. Your own personal private Wayback Machine that can also archive HTTP POST requests and responses, as well as most other HTTP-level data.

Files

Raw Source

Contents

{ pkgs ? import <nixpkgs> {}
, lib ? pkgs.lib
, source ? import ../source.nix { inherit pkgs; }
}:

with pkgs;

python3Packages.buildPythonApplication rec {
  pname = "hoardy-web-sas";
  version = "1.6.1";
  format = "pyproject";

  inherit (source) src unpackPhase;
  sourceRoot = "${src.name}/simple_server";

  propagatedBuildInputs = with python3Packages; [
    setuptools
    cbor2
  ];
}