software/hoardy-web/./default.nix

Passively capture, archive, and hoard your web browsing history, including the contents of the pages you visit, for later offline viewing, replay, mirroring, data scraping, and/or indexing. Your own personal private Wayback Machine that can also archive HTTP POST requests and responses, as well as most other HTTP-level data.

Files

Raw Source

Contents

{ pkgs ? import <nixpkgs> {}
, developer ? false
}:

let packages = import ./packages.nix { inherit pkgs developer; }; in

pkgs.buildEnv {
  name = "hoardy-web-env-20241109";
  paths = with packages; [
    simple_server
    extension
    tool
  ];
}