software/hoardy-web/./source.nix

Passively capture, archive, and hoard your web browsing history, including the contents of the pages you visit, for later offline viewing, mirroring, and/or indexing. Your own personal private Wayback Machine that can also archive HTTP POST requests and responses, as well as most other HTTP-level data.

Files

Raw Source

Contents

{ pkgs ? import <nixpkgs> {}
, lib ? pkgs.lib
}:

{

  src = lib.cleanSourceWith {
    src = ./.;
    filter = name: type: let baseName = baseNameOf (toString name); in
      (builtins.match ".*.un~" baseName == null)
      && (baseName != "dist")
      && (baseName != "result")
      && (baseName != "results")
      && (baseName != "__pycache__")
      && (baseName != ".mypy_cache")
      && (baseName != ".pytest_cache")
      && (builtins.match ".*/simple_server/pwebarc-dump.*" name == null)
      ;
  };

  unpackPhase = ''
    ${pkgs.git}/bin/git clone $src source
    ${pkgs.git}/bin/git clone $src/vendor/pako source/vendor/pako
    cp -a $src/extension/private source/extension || true
    patchShebangs source
    find source | grep -vF '/.git/'
  '';

}