software/hoardy-web/./packages.nix

Passively capture, archive, and hoard your web browsing history, including the contents of the pages you visit, for later offline viewing, mirroring, and/or indexing. Your own personal private Wayback Machine that can also archive HTTP POST requests and responses, as well as most other HTTP-level data.

Files

Raw Source

Contents

{ pkgs ? import <nixpkgs> {}
, debug ? false
}:

let source = import ./source.nix { inherit pkgs; }; in

{
  simple_server = import ./simple_server { inherit pkgs source; };
  extension = import ./extension { inherit pkgs source; };
  tool = import ./tool { inherit pkgs source debug; };
}