software/hoardy-web/./packages.nix

Passively capture, archive, and hoard your web browsing history, including the contents of the pages you visit, for later offline viewing, replay, mirroring, data scraping, and/or indexing. Your own personal private Wayback Machine that can also archive HTTP POST requests and responses, as well as most other HTTP-level data.

Files

Raw Source

Contents

{ pkgs ? import <nixpkgs> {}
, developer ? false
}:

let
  source = import ./source.nix { inherit pkgs; };
  args = { inherit pkgs source developer; };
in

{
  simple_server = import ./simple_server args;
  extension = import ./extension args;
  tool = import ./tool args;
}